Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5

Windows XP listing folderów i problem z polskimi znakami

#1
Witam Smile

Bardzo proszę zorientowanych o pomoc. Sprawa bardzo pilna.

Mama taki problem.
Robię sobie listing plików za pomocą DOS-oweg polecenia DIR, czyli odpalam cmd.exe, przewchodzę do folderu, który chcę wylistować. Następnie uruchamiam następujące polecenie: DIR /b > listing.txt i do pliku listing.txt zapisuje mi się lista wszytlich plików, które mnie interesują.

Mój problem polega na tym, iż nazwy plików zawierają "ogonki" (tak musi być) i w pliku listing.txt, w miejscach "ogonków" robią się "krzaki".

Pytanie.
Co zrobić, aby pozbyć się tych ogonków? Docelowo zawartość pliku listing.txt będę importował do Excela i tam poddawał dalszej obróbce-robił listę do drukowania, pozbywając się rozszerzeń.

Za każde info z góry dziękuję-bardzo!

Pozdrawiam Smile
Grzegorz
#2
Zmień przed zapisem do pliku tekstowego kodowanie znaków w konsoli cmd:
Wpisz po otwarciu konsoli:
Kod:
chcp 65001
//zmienia kodowanie na polskie znaki
a potem:
Kod:
DIR /b > listing.txt
#3
Jesteś WIELKI!!!
Dzięki serdeczne Smile


Pozdrawiam Smile
Grzegorz
#4
Przy importowaniu do Excela używasz tak samo: 65001 UNICODE (UTF-8) ...
#5
piotrino1 napisał(a):Przy importowaniu do Excela używasz tak samo: 65001 UNICODE (UTF-8) ...
Przyznaje, że w pierwszym momencie nie wiedziałem co wybrać, ale stwierdziłem, że ruszę trochę "mózgownicą", zwłaszcza, że naprowadziłeś mnie na to wczesniejszą odpowiedzią, podając cyferki "65001"

Mam jeszcze jeden problem. Może dasz radę ;-)
Miałem wirusa. Udało mi się go usunąć, ale pozostał po nim jeden problem.
Foldery-Element ukryty. Rejestracja zajmie tylko minutę! (WIN XP) mają czerwony wykrzyknik przy przegladaniu z poziomu Total Commandera, a przy przegladaniu z poziomu Exploratora, nie mają wykrzyknika, ale dla odmiany ikony mają wyblakłe - jak nieaktywne. Na początku w ogóle nie były widoczne, ale pogrzebałem we właściwościach folderów i usunąłem ptaszka z opcji:
> WIDOK > WYŚWIETL ZAWARTOŚĆ FOLDERÓW SYSTEMOWYCH.
Efekt jest taki, że z poziomu Exploratora i TC stały się widoczne, ale jak już np. zapisuje coś na dysku i szukam w liście tego folderu (z wykrzyknikiem lub wyblakłego), to na liście jest niewidoczny. Już wiem, że muszę pozbyć się tego wykrzyknika, żeby wszystko wróciło do normy i jest to zapewne sprawa atrybutów, ale atrybutów nie da się zmienić w żaden sposób, gdyż z poziomu Exploratora są nieaktywne, a zpoziomu innych programów niewidoczne.

Przychodzi Ci coś do głowy???


Jeszcze raz dziękuję Smile
#6
Grzegorz_n napisał(a):
piotrino1 napisał(a):Efekt jest taki, że z poziomu Exploratora i TC stały się widoczne, ale jak już np. zapisuje coś na dysku i szukam w liście tego folderu (z wykrzyknikiem lub wyblakłego), to na liście jest niewidoczny. Już wiem, że muszę pozbyć się tego wykrzyknika, żeby wszystko wróciło do normy i jest to zapewne sprawa atrybutów, ale atrybutów nie da się zmienić w żaden sposób, gdyż z poziomu Exploratora są nieaktywne, a zpoziomu innych programów niewidoczne.

Przychodzi Ci coś do głowy???


Jeszcze raz dziękuję Smile
A próbowałeś zmienić atrybuty w trybie awaryjnym z konta administratora???? Jak to nie pomoże to spróbuj zrobić przywracanie systemu do punktu gdzie wszystko ci działało...
#7
piotrino1 napisał(a):A próbowałeś zmienić atrybuty w trybie awaryjnym z konta administratora???? Jak to nie pomoże to spróbuj zrobić przywracanie systemu do punktu gdzie wszystko ci działało...
Wcześniej nie, ale teraz (po Twojej sugestii) wszedłem w tryb awaryjny i niestety nadal to samo - brak możliwości zmiany atrybutów.
Co do przywrócenia systemu, to to akurat nie echodzi w rachubę, gdyż to dysk przenośny i nie miał ustawionego punktu przywracania.

Ciekawe jest to, że jak utworze nowy folder, to ten zachowuje się prawidłowo. No wiem, można tak każdy folder zdublować, a potem ten z wykrzyknikiem usunąć, ale mam taką masę danych na tym dysku, że zajdzie mi na tym całe wieki.
#8
Grzegorz_n napisał(a):Miałem wirusa. Udało mi się go usunąć, ale pozostał po nim jeden problem.
Foldery-ikony (WIN XP) mają czerwony wykrzyknik przy przegladaniu z poziomu Total Commandera, a przy przegladaniu z poziomu Exploratora, nie mają wykrzyknika, ale dla odmiany ikony mają wyblakłe - jak nieaktywne. Na początku w ogóle nie były widoczne, ale pogrzebałem we właściwościach folderów i usunąłem ptaszka z opcji:
Spróbuj przeskanować ten dysk programem antywirusowym online np kasperski, lub eset.- Ściągnij też hijackthis - Element ukryty. Rejestracja zajmie tylko minutę!i zrób skanowanie dysku i daj mi log tu na forum... Sciągnij też Spybot-Sd Element ukryty. Rejestracja zajmie tylko minutę!
Jak to wszystko nie pomoże, to sięgniemy po "cięższą artylerię" Smile
  


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Problem z dużymi znakami diakrytycznymi w Firefoxie T-1000 12 734 23.08.2007 00:10
Ostatni post: Bitterman
  Windows XP problem z polskimi znakami hunter23 2 374 29.01.2003 14:14
Ostatni post: hunter23
  Windows XP problem z polskimi znakami Julia 2 413 17.11.2002 01:51
Ostatni post: Anonymous

Skocz do:


Użytkownicy przeglądający ten wątek:
2 gości